[Date Prev][Date Next][Thread Prev][Thread Next] [Date Index] [Thread Index]

Subject: Re: Automounter / NIS (indirekte maps)
From: Uwe Ortner
Date: 3 Mar 2000 12:04:17 -0000


Frank Derichsweiler wrote:

> On Thu, Mar 02, 2000 at 01:17:25PM +0000, Uwe Ortner wrote:
> > wenn ich auf LINUX (SuSe 6.1) versuche nachfolgende NIS-MAPS über
> > den automounter einzubinden,
> > kommt das System bei den indirekten Maps total ins schleudern.
> >
> Welches Verhalten ist zu beobachten?

Die mounts werden direkt auf / gelegt, d.h. das System stürzt komplett ab

>
>
> > Auch wenn ich versuche die maps direkt anzugeben (also ohne NIS,
> > direkt in /etc/auto* angegeben) gibts Chaos.
>
> Hier dieselbe Frage.
>

s.o. mounts werden nicht über NIS angefordert sondern sind explizit und
vollständig lokal (/etc/auto_*) angegeben
Sind nur direkte maps angegeben funktioniert alles.
Sind indirekte maps angegeben wird versucht das / zu übermounten -> crash
nach dem reboot existiert im / das Verzeichnis "-" was darauf schließen
läßt dass die Notation für indirekte maps ("/-") in der auto_master nicht
korrekt ist
PS: das gleiche funktioniert bei IBM/RS6000 Workstations AIX 4.3.2
problemlos!

> >
> > Unabhängig davon gibt der automounter (autofs status) den Status
> > falsch an  (vielleicht liegts an der Version d. automounters)
> >
> Meine Idee zur Fehlersuche: erst einmal "von Hand" (als root) mit
> mount -t nfs ... versuchen. Wenn dies klappt, weitersuchen. Noch
> etwas: hier gibt es ab und zu Probleme, wenn per automount in ein
> bestehendes Verzeichnis hineingemountet werden soll. Habe ich jedoch
> noch nicht naeher untersuchen koennen.
>

s.o.  ich kann alle Verzeichnisse per Hand wie auch über den automounter
mounten
solange (!) es keine indirekten maps sind.

>
> HTH
> Frank

Mit freundlichen Gruessen

Warm regards

Uwe Ortner (DEBIS)

Tel.: 0049 (8153) 30 - 4555
Fax : 0049 (8153) 30 - 2128
Mail: dea@faidor.de
Building 335/36