[Date Prev][Date Next][Thread Prev][Thread Next] [Date Index] [Thread Index]

Subject: Re: Inbox wird nicht "geleert"
From: Richard 'baum2000' Cattien
Date: 3 Mar 2000 18:03:38 -0000


On Fri, Mar 03, 2000 at 02:22:46PM +0000, Alexander Troppmann wrote:
> 
> Hallo!

Hallo auch

> In letzter Zeit häufen sich die Fälle, daß ich Mail doppelt bekomme.
> Auch andere Leute, die von unserem Linux-Server Mail holen bekommen
> zeitweise die gleichen Mails mehrmals hintereinander. Es hat sich
> herausgestellt, daß die mbox files in /var/spool/mail der User nicht
> "geleert" werden, nachdem diese Mail abholen, und daher bekommt man jede
> Mail beim nächsten Abholen natürlich wieder.
> 
> Die Frage ist nur: warum? :)
> 
> Ich hole Mail mit fetchpop ab und scheinbar holt fetchpop jede Mail erst
> und löscht dann alle auf einmal. Wenn also bei der 100tenm von 101 Mail
> was schief läuft und die Verbindung abbricht, geht alles wieder von
> vorne los.

korrekt

> Da unter Windows aber auch dieses Problem auftritt, kann es schlecht
> clientside sein, denek ich... Ich kenne das Problem auch von einem
> anderen Server unter RedHat Linux 6.x her, auch dort "hängt" mein mbox
> file und liefert jetzt alle Mails "immer wieder" sozusagen aus.

Also ich kenne jetzt fetchpop nicht, aber bei fetchmail kann man einstellen das es immer so 10 mails holen soll und diese dann vom server loeschen dann die naechsten 10 und so weiter. das kann man auch noch weiter runter setzen. Vielleicht gibts sowas in der Richtung auch fuer dein fetchpop. Wie das mit den anderen Clients ausschaut weiss ich leider nicht.

> Beide Server arbeiten mit RedHat 6.0 bzw. 6.1, der pop3d kommt aus dem
> imap-4.5-4 Package der Halloween IV Distribution.
> 
> Hat jemand eine Idee?

Richard