[Date Prev][Date Next][Thread Prev][Thread Next] [Date Index] [Thread Index]

Subject: TV-Karten bringt kein Bild (Haup PCI-FM)
From: schmieja
Date: 1 May 2001 14:39:32 -0000


Hallo,
da wollte ich mir meinen alten Rechner zum Zweitfernseher umfunktionieren
und hab mir also eine Happauge WinTV PCI-FM Karte besorgt (die ja unter
Linux funktionieren soll), aber , was ich auch probiere, bleibt das Fenster
von xtvscreen schwarz :-(

// Story
Erster Versuch, die karte unter NT zum Laufen zu bringen (mit den Treibern und
der Software auf der beigelegten CD ) ist daran gescheitert, daß die
Applikation keine Karte gefunden hat.
Zweiter Versuch: Platte gewechselt, darauf einfach frisch 98
installiert und dann mit der mitgelieferten Software.  Karte erkannt,
beim Start der Anwendung friert das ganze System ein. (Herrlich, einmal
etwas was absolut reproduzierbar ist ;-)

Hm, ich dachte, das würde am schnellsten funktionieren (!= am besten ).
Also dann doch schon unter Linux begonnen:
Kernelmodule compiliert, bttv-rpms installiert, Readmes gesucht und
gelesen und dann losprobiert.
Die Karte wird erkannt, Ton ist auch da, Sender lassen sich alle
einstellen, nur das Bild bleibt dunkel :-(  (Ja, ich habe das Capture
eingeschaltet).

// gecheckte Fehler

In der Doku habe ich bereits folgende Fehlermöglichkeiten gefunden:
- Videokarte muß unterstützt werden  ( lt. Hauppauge ist das bei meiner
  Diamond Stealth 64 der Fall)
- Videokarten mit S3 868 bzw 968 Chip  produzieren unsichtbare Speicher-
  Konflikte.  - Sowohl unter Win, wie untr Linux hat die manuelle
  Relocation des Speicherbereiches nichts geholfen.
- ggf muß der Speicher der Videokarte dem bttv-Modul mitgegeben
  werden.  auch versucht-kein Erfolg
- XFree68 sollte mind. Version 3.2 haben - meine hat 3.3.irgendwas
- X-Server mit 8, 16 und 24 Bit Farbtiefe probiert

// System
  wie gesagt schon etwas betagt, Baujahr 1994, pentium 90MHz, 64MByte Hauptspeicher,
  Diamond Stealth 64 - Videokartei, PCI-Bus natürlich,

  SUSE-Linux 6.4  mit Standard-Kernel 2.2.14 (nicht SUSE-Kern)


Meldungen:
May  1 16:12:49 oldtimer kernel: Linux video capture interface: v1.00
May  1 16:12:49 oldtimer kernel: i2c: initialized
May  1 16:12:50 oldtimer kernel: bttv0: Brooktree Bt878 (rev 17) bus: 0, devfn: 120, irq: 7, memory:
 0xf0800000.
May  1 16:12:50 oldtimer kernel: PCI: Increasing latency timer of device 00:78 to 64
May  1 16:12:50 oldtimer kernel: bttv: 1 Bt8xx card(s) found.
May  1 16:12:50 oldtimer kernel: bttv0: PLL: 28636363 => 35468950 ... ok
May  1 16:12:50 oldtimer kernel: bttv0: Hauppauge eeprom: tuner=Philips FM1216 (5)
May  1 16:12:50 oldtimer kernel: bttv0: fader chip: TEA6300
May  1 16:12:50 oldtimer kernel: bttv0: model: BT878(Hauppauge new)
May  1 16:12:50 oldtimer kernel: msp3400: daemon started
May  1 16:12:50 oldtimer kernel: msp3400: thread: sleep
May  1 16:12:50 oldtimer kernel: msp3400: init: chip=MSP3415D-B3, has NICAM support
May  1 16:12:50 oldtimer kernel: tuner: type is 5 (Philips PAL)
May  1 16:12:50 oldtimer kernel: msp3400: thread: wakeup
May  1 16:12:50 oldtimer kernel: msp3400: setvolume: 0:0 0x00 0x00
May  1 16:12:50 oldtimer kernel: msp3400: setmode: 0
May  1 16:12:50 oldtimer kernel: msp3400: carrier1 val:   284 / 4.5   NTSC
May  1 16:12:50 oldtimer kernel: msp3400: carrier1 val:   250 / 5.5   PAL B/G
May  1 16:12:50 oldtimer kernel: msp3400: carrier1 val:   285 / 6.0   PAL I
May  1 16:12:51 oldtimer kernel: msp3400: carrier1 val:   328 / 6.5   PAL D/K + SAT + SECAM
May  1 16:12:51 oldtimer kernel: msp3400: carrier2 val:   301 / 5.85  PAL D/K NICAM
May  1 16:12:51 oldtimer kernel: msp3400: carrier2 val:   309 / 6.25  PAL D/K1 FM-stereo
May  1 16:12:51 oldtimer kernel: msp3400: carrier2 val:   342 / 6.74  PAL D/K2 FM-stereo
May  1 16:12:51 oldtimer kernel: msp3400: carrier2 val:   358 / 7.02  PAL SAT FM-stereo s/b
May  1 16:12:51 oldtimer kernel: msp3400: carrier2 val:   365 / 7.20  PAL SAT FM-stereo s
May  1 16:12:51 oldtimer kernel: msp3400: carrier2 val:   363 / 7.38  PAL SAT FM-stereo b
May  1 16:12:51 oldtimer kernel: msp3400: setmode: 3
May  1 16:12:51 oldtimer kernel: msp3400: FM setstereo: 1
May  1 16:12:51 oldtimer kernel: msp3400: setvolume: 65535:65535 0x73 0x00
May  1 16:12:51 oldtimer kernel: msp3400: mono sound carrier: 6.501 MHz
May  1 16:12:51 oldtimer kernel: msp3400: thread: sleep


Ist jemand da, der jetzt noch Rat weiß ???

Andreas